Не могу договориться с yum

User avatar
Privet
Администратор
Posts: 16575
Joined: 03 Jan 1999 10:01
Location: Redmond, WA

Не могу договориться с yum

Post by Privet » 03 Jul 2019 08:26

Сюжет такой: zoneminder был установлен с репозитория rpmfusion и были проблемы с установкой. Я его отключил и активировал zmrepo. Со старого репозитория осталась грязи и установка не пошла. Я удалил всё (как я думаю), что оставалось от прошлого репозитория, но всё равно идут ошибки.
Я не могу понять что делать. Компоненты, которые нужны, вроде как, есть, но они не устанавливаются. Что я могу сделать?

Code: Select all

[root@web ~]# yum install zoneminder
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: linux.mirrors.es.net
 * centosplus: mirror.sjc02.svwh.net
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * extras: mirror.fileplanet.com
 * remi-php72: mirror.sjc02.svwh.net
 * remi-php73: mirror.sjc02.svwh.net
 * remi-safe: mirror.sjc02.svwh.net
 * updates: mirror.linuxfix.com
 * zmrepo: zmrepo.connortechnology.com
Resolving Dependencies
--> Running transaction check
---> Package zoneminder.x86_64 0:1.30.4-1.el7.centos will be installed
--> Processing Dependency: vlc-core for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libswscale.so.3(LIBSWSCALE_3)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavutil.so.54(LIBAVUTIL_54)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavformat.so.56(LIBAVFORMAT_56)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavcodec.so.56(LIBAVCODEC_56)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: ffmpeg for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libvlc.so.5()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libswscale.so.3()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavutil.so.54()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavformat.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavdevice.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavcodec.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Running transaction check
---> Package ffmpeg.x86_64 0:3.4.6-1.el7 will be installed
--> Processing Dependency: ffmpeg-libs(x86-64) = 3.4.6-1.el7 for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libswscale.so.4(LIBSWSCALE_4)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libswresample.so.2(LIBSWRESAMPLE_2)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libpostproc.so.54(LIBPOSTPROC_54)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavutil.so.55(LIBAVUTIL_55)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavresample.so.3(LIBAVRESAMPLE_3)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavformat.so.57(LIBAVFORMAT_57)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavfilter.so.6(LIBAVFILTER_6)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavdevice.so.57(LIBAVDEVICE_57)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57(LIBAVCODEC_57)(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libswscale.so.4()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libswresample.so.2()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libpostproc.so.54()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavutil.so.55()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavresample.so.3()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavformat.so.57()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavfilter.so.6()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavdevice.so.57()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
--> Processing Dependency: libavcodec.so.57()(64bit) for package: ffmpeg-3.4.6-1.el7.x86_64
---> Package ffmpeg-libs.x86_64 0:2.8.15-1.el7 will be installed
--> Processing Dependency: libswscale.so.3(LIBSWSCALE_3)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libswscale.so.3()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavutil.so.54(LIBAVUTIL_54)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavutil.so.54()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavformat.so.56(LIBAVFORMAT_56)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavformat.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavcodec.so.56(LIBAVCODEC_56)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavcodec.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
---> Package libavdevice.x86_64 0:2.8.15-1.el7 will be installed
--> Processing Dependency: libavdevice.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
---> Package vlc-core.x86_64 1:3.0.7.1-4.el7 will be installed
--> Running transaction check
---> Package ffmpeg-libs.x86_64 0:2.8.15-1.el7 will be installed
--> Processing Dependency: libswscale.so.3(LIBSWSCALE_3)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libswscale.so.3()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavutil.so.54(LIBAVUTIL_54)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavutil.so.54()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavformat.so.56(LIBAVFORMAT_56)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavformat.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavcodec.so.56(LIBAVCODEC_56)(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
--> Processing Dependency: libavcodec.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
---> Package ffmpeg-libs.x86_64 0:3.4.6-1.el7 will be installed
---> Package libavdevice.x86_64 0:2.8.15-1.el7 will be installed
--> Processing Dependency: libavdevice.so.56()(64bit) for package: zoneminder-1.30.4-1.el7.centos.x86_64
---> Package libavdevice.x86_64 0:3.4.6-1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libswscale.so.3(LIBSWSCALE_3)(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libswscale.so.2(LIBSWSCALE_2)(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libswscale.so.4(LIBSWSCALE_4)(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libswscale.so.4(LIBSWSCALE_4)(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libswscale.so.4(LIBSWSCALE_4)(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libswscale.so.4(LIBSWSCALE_4)(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libavformat.so.56()(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libavformat.so.55()(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavformat.so.57()(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavformat.so.57()(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavformat.so.57()(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavformat.so.57()(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libavcodec.so.56(LIBAVCODEC_56)(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libavcodec.so.55(LIBAVCODEC_55)(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavcodec.so.57(LIBAVCODEC_57)(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavcodec.so.57(LIBAVCODEC_57)(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavcodec.so.57(LIBAVCODEC_57)(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavcodec.so.57(LIBAVCODEC_57)(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libavcodec.so.56()(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libavcodec.so.55()(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavcodec.so.57()(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavcodec.so.57()(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavcodec.so.57()(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavcodec.so.57()(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libavutil.so.54(LIBAVUTIL_54)(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libavutil.so.52(LIBAVUTIL_52)(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavutil.so.55(LIBAVUTIL_55)(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavutil.so.55(LIBAVUTIL_55)(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavutil.so.55(LIBAVUTIL_55)(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavutil.so.55(LIBAVUTIL_55)(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.11-1.el7.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.12-1.el7.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.13-1.el7.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.13-2.el7.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.14-1.el7.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-2.8.15-1.el7.x86_64 (zmrepo)
               libavdevice.so.56()(64bit)
           Available: libavdevice-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavdevice.so.57()(64bit)
           Available: libavdevice-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavdevice.so.57()(64bit)
           Available: libavdevice-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavdevice.so.57()(64bit)
           Installing: libavdevice-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavdevice.so.57()(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libswscale.so.3()(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libswscale.so.2()(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libswscale.so.4()(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libswscale.so.4()(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libswscale.so.4()(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libswscale.so.4()(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libavformat.so.56(LIBAVFORMAT_56)(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libavformat.so.55(LIBAVFORMAT_55)(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavformat.so.57(LIBAVFORMAT_57)(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavformat.so.57(LIBAVFORMAT_57)(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavformat.so.57(LIBAVFORMAT_57)(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavformat.so.57(LIBAVFORMAT_57)(64bit)
Error: Package: zoneminder-1.30.4-1.el7.centos.x86_64 (zmrepo)
           Requires: libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.7-1.el7.centos.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.11-1.el7.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.12-1.el7.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.13-1.el7.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.13-2.el7.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.14-1.el7.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.8.15-1.el7.x86_64 (zmrepo)
               libavutil.so.54()(64bit)
           Available: ffmpeg-libs-2.1.5-1.el7.centos.x86_64 (zmrepo)
              ~libavutil.so.52()(64bit)
           Available: ffmpeg-libs-3.4.5-1.el7.x86_64 (zmrepo)
              ~libavutil.so.55()(64bit)
           Available: ffmpeg-libs-3.4.5-2.el7.x86_64 (zmrepo)
              ~libavutil.so.55()(64bit)
           Available: ffmpeg-libs-3.4.5-3.el7.x86_64 (zmrepo)
              ~libavutil.so.55()(64bit)
           Installing: ffmpeg-libs-3.4.6-1.el7.x86_64 (zmrepo)
              ~libavutil.so.55()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@web ~]#
Привет.

User avatar
aleh
Уже с Приветом
Posts: 1919
Joined: 19 Nov 2000 10:01
Location: BY-MA-RI-CT-MO

Re: Не могу договориться с yum

Post by aleh » 03 Jul 2019 22:16

Ну оно ж вам подсказывает:

Code: Select all

 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
PS:
Еще можно

Code: Select all

yum clean all
 yum update
Last edited by aleh on 03 Jul 2019 22:27, edited 1 time in total.
"Нет поэтов в родне, инженеры одне..."

User avatar
Privet
Администратор
Posts: 16575
Joined: 03 Jan 1999 10:01
Location: Redmond, WA

Re: Не могу договориться с yum

Post by Privet » 03 Jul 2019 22:26

Это ерунда всё. Типа, не работает? Да и хрен с ней.

Она требует конкретную версию неких пакетов, а в том, что инсталлируется есть только более старшие версии. Похоже, это ошибка тех, кто собирал пакеты.
Я нашёл другой пакет. Заработал, но камеры пока оживают только наполовину. Вроде как работают, но ничего не кажут. Ладно, хоть так. Утопчу...
Привет.

User avatar
aleh
Уже с Приветом
Posts: 1919
Joined: 19 Nov 2000 10:01
Location: BY-MA-RI-CT-MO

Re: Не могу договориться с yum

Post by aleh » 04 Jul 2019 03:37

Для видеокамер я, кстати, кручу motioneyeOS в доккере на сервере. Просто и сердито.
"Нет поэтов в родне, инженеры одне..."

Return to “Вопросы и новости IT”