Vito’s Family

и задачки для интервью.
User avatar
IvanGrozniy
Уже с Приветом
Posts: 10526
Joined: 04 Feb 2004 14:14
Location: Edgewater, NJ

Vito’s Family

Post by IvanGrozniy »

Есть задача:
The famous gangster Vito Deadstone is moving to New York. He has a very big
family there, all of them living on Lamafia Avenue. Since he will visit all his relatives
very often, he wants to find a house close to them.
Indeed, Vito wants to minimize the total distance to all of his relatives and has
blackmailed you to write a program that solves his problem.
Input
The input consists of several test cases. The first line contains the number of test cases.
For each test case you will be given the integer number of relatives r (0 < r < 500) and
the street numbers (also integers) s1, s2, . . . , si, . . . , sr where they live (0 < si < 30, 000).
Note that several relatives might live at the same street number.
Output
For each test case, your program must write the minimal sum of distances from the
optimal Vito’s house to each one of his relatives. The distance between two street
numbers si and sj is dij = |si − sj |.
Sample Input
2
2 2 4
3 2 4 6
Sample Output
2
4


Есть достаточно простое решение на мой взгляд.

Code: Select all

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace _4_8_1
{
    class Program
    {
        static void Main(string[] args)
        {
            int[] arr0 = {2, 4};
            Calc(arr0);
            int[] arr1 = { 2, 4, 6 };
            Calc(arr1);
            Console.ReadKey();
        }
        static void Calc(int[] arr)
        {
            int[] sum = new int[arr.Length];
            for (int i = 0; i < sum.Length; i++)
                sum[i] = 0;
            for (int i = 0; i < sum.Length; i++)
                for (int j = 0; j < arr.Length; j++)
                    sum[i] += Math.Abs(arr[j] - arr[i]);
            Array.Sort(sum);
            Console.WriteLine(sum[0]);
        }
    }
}


Смущает подсказка
What is the right version of average to solve Vito’s problem: mean, median, or something else?

Что автор имел ввиду под этой подсказкой?
kludge
Уже с Приветом
Posts: 189
Joined: 30 Aug 2006 23:28

Re: Vito’s Family

Post by kludge »

IvanGrozniy wrote:Смущает подсказка
What is the right version of average to solve Vito’s problem: mean, median, or something else?

Что автор имел ввиду под этой подсказкой?


Это намек на то, что решать можно не перебором (квадратичной сложности) а вычислением некоего "среднего" номера дома.

PS: а почему вы пытаетесь поселить Вито обязательно у кого-нибудь из родственников (или мне так с похмелья показалось)?
User avatar
IvanGrozniy
Уже с Приветом
Posts: 10526
Joined: 04 Feb 2004 14:14
Location: Edgewater, NJ

Re: Vito’s Family

Post by IvanGrozniy »

kludge wrote:PS: а почему вы пытаетесь поселить Вито обязательно у кого-нибудь из родственников (или мне так с похмелья показалось)?

Хм. Теперь понятно, что ничего не понятно. :?
Сдаётся мне, что надо мат. ожидание считать. Это так?
kludge
Уже с Приветом
Posts: 189
Joined: 30 Aug 2006 23:28

Re: Vito’s Family

Post by kludge »

IvanGrozniy wrote:
kludge wrote:PS: а почему вы пытаетесь поселить Вито обязательно у кого-нибудь из родственников (или мне так с похмелья показалось)?

Хм. Теперь понятно, что ничего не понятно. :?
Сдаётся мне, что надо мат. ожидание считать. Это так?


Не знаю. Навскидку кажется, что медиана. Правдоподобные рассуждения есть, а доказывать с похмелья не могу.
User avatar
IvanGrozniy
Уже с Приветом
Posts: 10526
Joined: 04 Feb 2004 14:14
Location: Edgewater, NJ

Post by IvanGrozniy »

Похоже, что действительно надо использовать медиану.
Вот исправленное решение

Code: Select all

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace _4_8_1
{
    class Program
    {
        static void Main(string[] args)
        {
            int[] arr0 = {2, 4};
            Calc(arr0);
            int[] arr1 = { 2, 4, 6 };
            Calc(arr1);
            Console.ReadKey();
        }
        static void Calc(int[] arr)
        {
            Array.Sort(arr);
            double medIndex = arr.Length / 2;
            int med = 0;
            if (arr.Length % 2 == 0)
                med = arr[arr.Length / 2 - 1] + (arr[arr.Length / 2] - arr[arr.Length / 2 - 1]) / 2;
            else
                med = arr[arr.Length / 2];

            int sum = 0;
            for (int i = 0; i < arr.Length; i++)
               sum += Math.Abs(arr[i] - med);
            Console.WriteLine(sum);
        }
    }
}

Return to “Головоломки”